Ubuntu: Package libapache2-mod-fastcgi is not available

Dalam Artikel ini akan dibahas cara mengatasi error Package libapache2-mod-fastcgi is not available saat kita install modul fast-cgi di Ubuntu Linux.

Kapan Pesan Error Package libapache2-mod-fastcgi is not available muncul ?

Pesan Error ini Muncul saat kita memberikan perintah berikut:

apt-get install libapache2-mod-fastcgi

Pesan Error Selengkapnya adlah sebagai berikut:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libapache2-mod-fastcgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libapache2-mod-fastcgi' has no installation candidate

Cara Mengatasi Pesan Error Package libapache2-mod-fastcgi is not available

Penyebab utama dari masalah ini adalah multiverse repository tidak terdaftar di apt sources, dan salah satunya adalah libapache2-mod-fastcgi.

Untuk mengatasi Masalah ini, edit /etc/apt/sources.list. Edit File ini dengan menggunakan vim atau nano :

nano /etc/apt/sources.list

Kemudia Tambahkan Baris berikut:

deb http://us.archive.ubuntu.com/ubuntu/ wily multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ wily multiverse
deb http://us.archive.ubuntu.com/ubuntu/ wily-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ wily-updates multiverse

Silahkan ganti willy sesuai dengan versi ubuntu Anda.
Setelah itu update dan install libapache2-mod-fastcgi dengan perintah berikut:

sudo apt-get update && sudo apt-get install libapache2-mod-fastcgi

Selamat mencoba.. !

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

loading...